AtomのPHPCSでWarning – WordPress

AtomエディタでWordPressのプラグインやテーマを編集する際に、
PHPCSのエラーが表示されるようになったので環境を見直しました。

macOS High Sierra 10.13.4
Atom 1.25.0
linter-phpcs 1.6.8

こちらの記事に感謝。
WordPressのコーディング規約をPHP CodeSnifferでチェックしてPhpStormでもチェックと自動整形する

composer で phpcs をインストール
$ composer global require "squizlabs/php_codesniffer=*"

WordPress用のコーディング規約をインストール
$ git clone git@github.com:WordPress-Coding-Standards/WordPress-Coding-Standards.git \
~/.composer/vendor/squizlabs/php_codesniffer/CodeSniffer/Standards/WordPress

コーディング規約をWordPressに登録
$ phpcs --config-set installed_paths ~/.composer/vendor/squizlabs/php_codesniffer/CodeSniffer/Standards/WordPress

コーディング規約の確認
phpcs -i

Atomのlinter-phpcs設定(executable path)
/Users/(username)/.composer/vendor/bin/phpcs