Categories
Android

Gradle build error on Android Studio 0.5.2

しばらくぶりに Android Studio を使ってみようと思い、あらためてインストール。

新規プロジェクトを作成しようとすると
Messages Gradle tasks に

Error:Execution failed for task ':app:preBuild'.
> Build Tools Revision 19.0.0+ is required.

のエラー。

ちなみに、Tools -> Android -> SDK Manager
menu-sdk-manager
を開いてUpdateを実行して、Build-tools 19.0.3 がインストールされているのは確認済み。

いろいろ調べたところ、
http://stackoverflow.com/questions/22247548/upgraded-android-studio-project-no-longer-builds-gradle-build-tools-version
このような記事があったので、これを参考に、
appフォルダ内の build.gradle を編集。

[before edit]

android {
    compileSdkVersion 18
    buildToolsVersion "18.0.1"
...

[after edit]

android {
    compileSdkVersion 19
    buildToolsVersion "19.0.3"
...

このようにするとビルドできました。

【追記】2014.04.01
3月27日付けでAndroid Studio 0.5.3 がリリースされていました。
アップデートして、あらたにプロジェクトを作成したところ、デバッグ実行で特にエラーもなくHello Worldの表示ができました。